Returns an instance DWGExportOptions containing settings from a predefined export setup.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
-
Type:
Autodesk.Revit.DB
Document
A Revit project document to retrieve the setup from.
- setup
-
Type:
System
String
The name of a predefined export setup from the specified document.
Return Value
An instance of predefined DWGExportOptions, or a null reference ( Nothing in Visual Basic) if the name was not found.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | document is not a project document. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |