GetSolidPatternId Method


Gets the solid line pattern element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public static ElementId GetSolidPatternId()
Visual Basic
Public Shared Function GetSolidPatternId As ElementId
Visual C++
public:
static ElementId^ GetSolidPatternId()

Return Value

The element id of the solid line pattern.

Remarks

Note that Solid is special. It isn't a line pattern at all -- it is a special code that tells drawing and export code to use solid lines rather than patterned lines. Solid is visible to the user when selecting line patterns.

See Also