Adds a regular field at the specified position in the list.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fieldType
-
Type:
Autodesk.Revit.DB
ScheduleFieldType
The type of data displayed by the field.
- index
-
Type:
System
Int32
The index in the list of fields.
Return Value
The new field.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | index is not a valid insert position. -or- A value passed for an enumeration argument is not a member of that enumeration |