Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- formatOptions
-
Type:
Autodesk.Revit.DB
FormatOptions
The FormatOptions.
Remarks
See the UnitType property to determine the unit type of this dimension style.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The display unit in formatOptions is not a valid display unit for the unit type of this DimensionType, or the rounding method in formatOptions is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |