ViewId Property


The element id of the view to export. InvalidElementId by default. Used only when ExportScope = View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public ElementId ViewId { get; set; }
Visual Basic
Public Property ViewId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ ViewId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also