Creates a new fluid type and adds it to the document.
Namespace:
Autodesk.Revit.DB.Plumbing
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
-
Type:
Autodesk.Revit.DB
Document
The document.
- fluidTypeName
-
Type:
System
String
The name of new created fluid type.
- basedOnFluidType
-
Type:
Autodesk.Revit.DB.Plumbing
FluidType
The existing fluid type which is based on.
Return Value
The newly created fluid type.Remarks
The new fluid type will be a duplicate of the input type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |