ProjectPhase Property


The project phase of the EnergyData information.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public ElementId ProjectPhase { get; set; }
Visual Basic
Public Property ProjectPhase As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ ProjectPhase {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: The input element is not a project phase.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also