RectangleLightShape Class


This class encapsulates a rectangle light shape.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public class RectangleLightShape : LightShape
Visual Basic
Public Class RectangleLightShape _
	Inherits LightShape
Visual C++
public ref class RectangleLightShape : public LightShape

Inheritance Hierarchy

System Object
Autodesk.Revit.DB.Lighting LightShape
Autodesk.Revit.DB.Lighting RectangleLightShape

See Also