Position Property


The position of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public XYZ Position { get; set; }
Visual Basic
Public Property Position As XYZ
	Get
	Set
Visual C++
public:
property XYZ^ Position {
	XYZ^ get ();
	void set (XYZ^ value);
}

Remarks

This is an alternate interface to the property CoordinateSystem.Origin. When set, the effect is the same as setting the CoordinateSystem property to the same as its current value but with a different Origin.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException Thrown when CoordinateSystem is set while the Reference property is not a null reference ( Nothing in Visual Basic) , and the ReferencePoint is unable to move to the new location.

See Also