AsTextRange Method


Returns a TextRange object that represents the entire text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2017

Syntax

C#
public TextRange AsTextRange()
Visual Basic
Public Function AsTextRange As TextRange
Visual C++
public:
TextRange^ AsTextRange()

Return Value

The TextRange object that represents the entire text.

Remarks

This range includes a carriage return character ('\r') that is always present. As a result the range can never be an empty range.

See Also