CropBox Property


The Crop Box applied to the view, or an outline encompassing the crop region applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public BoundingBoxXYZ CropBox { get; set; }
Visual Basic
Public Property CropBox As BoundingBoxXYZ
	Get
	Set
Visual C++
public:
property BoundingBoxXYZ^ CropBox {
	BoundingBoxXYZ^ get ();
	void set (BoundingBoxXYZ^ value);
}

Field Value

a null reference ( Nothing in Visual Basic) if the view is a template, or does not support cropping. If the view is cropped by a sketched region instead of by a box, the box will contain a box which outlines the extends of the sketch. Setting the crop box for a view cropped by a sketched region will have no effect. For better access to the crop region of a given view regardless of shape, use the return from GetCropRegionShapeManager .

Remarks

The X direction of the box is right on screen; Y, up; Z, towards the user. The crop box Z value of a plan view is not meaningful.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException Cannot set the CropBox of the specified view.

See Also