Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since:
2016 Subscription Release
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
-
Type:
Autodesk.Revit.DB
Document
The document.
- tap
-
Type:
Autodesk.Revit.DB
FabricationPart
The connected fabrication part tap to rotate.
- primaryAxisRotateBy
-
Type:
System
Double
The primary axis rotation angle in radians to rotate by.
- secondaryAxisRotateBy
-
Type:
System
Double
The secondary axis rotation angle in radians to rotate by.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Is not connected as a fabrication part tap. -or- tap cannot be rotated about the primary axis by the specified angle: primaryAxisRotateBy -or- tap cannot be rotated about the secondary axis by the specified angle: secondaryAxisRotateBy |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |