Optimizes the length fabrication straight parts.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since:
2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
-
Type:
Autodesk.Revit.DB
Document
The document.
- partIds
-
Type:
System.Collections.Generic
ISet
ElementId
The ids of the fabrication parts in a selected fabrication part run.
Return Value
New and modified fabrication part ids in the optimizeExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | There are no straight parts to optimize, or all parts are locked or locked by group membership. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | this operation failed. |