Align the part by its insertion point to a point and rotation on a straight. This will automatically size and connect the part being cut into, if possible.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since:
2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
-
Type:
Autodesk.Revit.DB
Document
The document.
- straightId
-
Type:
Autodesk.Revit.DB
ElementId
The element identifier of the straight to be cut in to.
- partId
-
Type:
Autodesk.Revit.DB
ElementId
The element identifier of the part to align and cut in with.
- position
-
Type:
Autodesk.Revit.DB
XYZ
The position to move the parts insertion point to.
- rotation
-
Type:
System
Double
The rotation in radians.
- slope
-
Type:
System
Double
The slope value to flex to match if possible in fractional units (eg.1/50). Positive values are up, negative are down. Slopes can only be applied to fittings, whilst straights will inherit the slope from the piece it is connecting to.
- flip
-
Type:
System
Boolean
Flip the part to allow for flow direction.
Return Value
True if the alignment succeeds, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element is not a fabrication part. -or- Not all of the fabrication part's connectors are open. -or- The part is not a straight. -or- The fabrication parts do not have matching domain types. -or- The position is not on the straight. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | Failed to align the part to the straight to cut in to. |