AddPoints Method


Adds points to a topography surface.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public void AddPoints(
	IList<XYZ> points
)
Visual Basic
Public Sub AddPoints ( _
	points As IList(Of XYZ) _
)
Visual C++
public:
void AddPoints(
	IList<XYZ^>^ points
)

Parameters

points
Type: System.Collections.Generic IList XYZ
A collection of points to be added.

Remarks

If an input point already exists in the surface at the same XY location, the point will not be added. The document will be regenerated by this function. This applies to a TopographySurface element (not a SiteSubRegion or a topography surface associated with a BuildingPad), which shoule be in an active TopographyEditScope.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException There are no points in the input points set. -or- One or more points shared the same XY location (even with different elevations). This is not permitted for topography surfaces.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException This element is not a TopographySurface. -or- The topography surface is not editable. -or- The TopographySurface element is not in an active TopographyEditScope. Modification cannot be made on this TopographySurface.
Autodesk.Revit.Exceptions ModificationForbiddenException The document containing this TopographySurface is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this TopographySurface is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions ModificationOutsideTransactionException The document containing this TopographySurface has no open transaction.

See Also