Checks to see if this part can be changed to the specified product entry without altering any connected dimensions.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since:
2016 Subscription Release
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- productEntry
-
Type:
System
Int32
The product entry index.
Return Value
Returns true if the part can be changed to the specified product entry without altering any connected dimensions.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The product entry index is not larger than 0 and less than GetProductCount. |