GetRenderingAsset Method


Gets the rendering asset for the appearance asset element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.13)
Since: 2014

Syntax

C#
public Asset GetRenderingAsset()
Visual Basic
Public Function GetRenderingAsset As Asset
Visual C++
public:
Asset^ GetRenderingAsset()

Return Value

The rendering asset held by this appearance asset element.

Remarks

The retrieved Asset may be empty if it is loaded from material library without any modification. In this case, you can use Application.GetAssets(AssetType.Appearance) to load all preset appearance assets, and retrieve the asset by its name.

See Also