FindByName Method


Gets the property with the given name.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.13)
Since: 2018.1

Syntax

C#
public AssetProperty FindByName(
	string name
)
Visual Basic
Public Function FindByName ( _
	name As String _
) As AssetProperty
Visual C++
public:
AssetProperty^ FindByName(
	String^ name
)

Parameters

name
Type: System String
Name of the property.

Return Value

The property with the specified name.

Remarks

FindByName will not visit the properties of the asset connected to a property. To visit the properties of the connected assets, use Item[String] instead.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also