SetPresentationMode Method


Sets the presentation mode for this rebar set when displayed in the given view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public void SetPresentationMode(
	View dBView,
	RebarPresentationMode presentationMode
)
Visual Basic
Public Sub SetPresentationMode ( _
	dBView As View, _
	presentationMode As RebarPresentationMode _
)
Visual C++
public:
void SetPresentationMode(
	View^ dBView, 
	RebarPresentationMode presentationMode
)

Parameters

dBView
Type: Autodesk.Revit.DB View
The view.
presentationMode
Type: Autodesk.Revit.DB.Structure RebarPresentationMode
The presentation mode.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException This rebar cannot have a presentation mode applied for dBView, as the view is not valid for rebar presentation, or the orientation of the view matches the normal direction of the rebar element.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions InapplicableDataException This rebar element represents a single bar (the layout rule is Single).

See Also