FitDirection Property


The fit direction. Used only if ZoomType is FitToPage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public FitDirectionType FitDirection { get; set; }
Visual Basic
Public Property FitDirection As FitDirectionType
	Get
	Set
Visual C++
public:
property FitDirectionType FitDirection {
	FitDirectionType get ();
	void set (FitDirectionType value);
}

Remarks

The default is Horizontal.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also