FamilyInstanceCreationData Constructor (FamilySymbol, IList(XYZ))


Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)

Syntax

C#
public FamilyInstanceCreationData(
	FamilySymbol symbol,
	IList<XYZ> adaptivePoints
)
Visual Basic
Public Sub New ( _
	symbol As FamilySymbol, _
	adaptivePoints As IList(Of XYZ) _
)
Visual C++
public:
FamilyInstanceCreationData(
	FamilySymbol^ symbol, 
	IList<XYZ^>^ adaptivePoints
)

Parameters

symbol
Type: Autodesk.Revit.DB FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
adaptivePoints
Type: System.Collections.Generic IList XYZ
The adaptive points where the adaptive instance is to be initialized.

See Also