GetConnectedPropertiesNames Method


Gets names of all connected properties.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2014

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you use the 'GetSingleConnectedAsset' method instead.")]
public IList<string> GetConnectedPropertiesNames()
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you use the 'GetSingleConnectedAsset' method instead.")> _
Public Function GetConnectedPropertiesNames As IList(Of String)
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you use the 'GetSingleConnectedAsset' method instead.")]
public:
IList<String^>^ GetConnectedPropertiesNames()

Return Value

A list of the names of the connected properties.

See Also