GetConnectedProperty Method (String)


Gets a connected property by its name.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2014

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you use the 'GetSingleConnectedAsset' method instead.")]
public AssetProperty GetConnectedProperty(
	string name
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you use the 'GetSingleConnectedAsset' method instead.")> _
Public Function GetConnectedProperty ( _
	name As String _
) As AssetProperty
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you use the 'GetSingleConnectedAsset' method instead.")]
public:
AssetProperty^ GetConnectedProperty(
	String^ name
)

Parameters

name
Type: System String
Name of the property.

Return Value

The property with the specified name.

Remarks

Returns NULL is there is no connected property with the specified name.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also