Returns the
ListType
of a paragraph.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since:
2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- textRange
-
Type:
Autodesk.Revit.DB
TextRange
The given text range.
Return Value
The ListType of the paragraph.Remarks
This function returns the list type of all paragraphs contained in the given range.
Returns
None
if the paragraph is not in a list.
Returns
Mixed
if the list types don't match between the paragraphs.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |