Creates a new AreaReinforcement object based on a host boundary.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since:
2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
-
Type:
Autodesk.Revit.DB
Document
The document.
- hostElement
-
Type:
Autodesk.Revit.DB
Element
The element that will host the AreaReinforcement. The host can be a Structural Floor, Structural Wall, Structural Slab, or a Part created from a structural layer belonging to one of those element types.
- majorDirection
-
Type:
Autodesk.Revit.DB
XYZ
A vector to define the major direction of the AreaReinforcement.
- areaReinforcementTypeId
-
Type:
Autodesk.Revit.DB
ElementId
The id of the AreaReinforcementType.
- rebarBarTypeId
-
Type:
Autodesk.Revit.DB
ElementId
The id of the RebarBarType.
- rebarHookTypeId
-
Type:
Autodesk.Revit.DB
ElementId
The id of the RebarHookType. If this parameter is InvalidElementId, it means to create a rebar with no hooks.
Return Value
The newly created AreaReinforcement.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element hostElement was not found in the given document. -or- the host Element is not a valid host for Area Reinforcement, Path Reinforcement, Fabric Area or Fabric Sheet. -or- areaReinforcementTypeId should refer to an AreaReinforcementType element. -or- rebarBarTypeId should refer to an RebarBarType element. -or- rebarHookTypeId should be invalid or refer to an RebarHookType element. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | majorDirection has zero length. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions ForbiddenForDynamicUpdateException | This method may not be called during dynamic update. |