SetDataType Method


Sets the parameter's data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015

Syntax

C#
public void SetDataType(
	ForgeTypeId dataType
)
Visual Basic
Public Sub SetDataType ( _
	dataType As ForgeTypeId _
)
Visual C++
public:
void SetDataType(
	ForgeTypeId^ dataType
)

Parameters

dataType
Type: Autodesk.Revit.DB ForgeTypeId
The identifier of either a spec or a category. A category identifier indicates a Family Type parameter of that category.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The given identifier is neither a spec nor a category.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also