Constructs a new instance of a filter to match elements by category.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryId
-
Type:
Autodesk.Revit.DB
ElementId
The category id to match.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The category was not valid for filtering. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |