ExternalDefinitionCreationOptions Constructor


Constructs the options using a specified name and type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015

Syntax

C#
[ObsoleteAttribute("This constructor is deprecated in Revit 2022 and may be removed in a future version of Revit. Please use the ExternalDefinitionCreationOptions(string, ForgeTypeId) overload instead.")]
public ExternalDefinitionCreationOptions(
	string name,
	ParameterType type
)
Visual Basic
<ObsoleteAttribute("This constructor is deprecated in Revit 2022 and may be removed in a future version of Revit. Please use the ExternalDefinitionCreationOptions(string, ForgeTypeId) overload instead.")> _
Public Sub New ( _
	name As String, _
	type As ParameterType _
)
Visual C++
[ObsoleteAttribute(L"This constructor is deprecated in Revit 2022 and may be removed in a future version of Revit. Please use the ExternalDefinitionCreationOptions(string, ForgeTypeId) overload instead.")]
public:
ExternalDefinitionCreationOptions(
	String^ name, 
	ParameterType type
)

Parameters

name
Type: System String
The name of the parameter definition to be created.
type
Type: Autodesk.Revit.DB ParameterType
The name of the parameter type for the new definition.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException type cannot be Invalid or FamilyType.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also