Sets the characters in a given text range to be in all caps or not.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- textRange
-
Type:
Autodesk.Revit.DB
TextRange
The given text range.
- isAllCaps
-
Type:
System
Boolean
The desired all caps status of characters in the given text range. True will render all characters in all caps. False will revert the characters back to their original mixed case.
Remarks
Removing the all caps status will revert the characters back to their original case. It will not make them lower case.
The given text range should not be empty.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |