Whether or not the parameter values can vary across group members.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
-
Type:
Autodesk.Revit.DB
Document
The document of this parameter.
- allowVaryBetweenGroups
-
Type:
System
Boolean
Whether this parameter should be allowed to vary between groups.
Return Value
The ids of elements that were updated to align the values between groups.Remarks
When a parameter is set to not vary between groups Revit will automatically align the parameter values
of any elements that actually varied between group instances.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This parameter does not support the specified value of allowVaryBetweenGroups. -or- document is not a project document. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |