UseCurrentViewOnly Property


True if only elements visible in the currently active view are used for generation of Energy Model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool UseCurrentViewOnly { get; set; }
Visual Basic
Public Property UseCurrentViewOnly As Boolean
	Get
	Set
Visual C++
public:
property bool UseCurrentViewOnly {
	bool get ();
	void set (bool value);
}

Remarks

This setting is ignored if the currently active view is not a 3D view or AnalysisType is RoomsOrSpaces.

See Also