SlabShapeEditor Property


Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Use GetSlabShapeEditor() instead.")]
public SlabShapeEditor SlabShapeEditor { get; }
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Use GetSlabShapeEditor() instead.")> _
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
	Get
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Use GetSlabShapeEditor() instead.")]
public:
property SlabShapeEditor^ SlabShapeEditor {
	SlabShapeEditor^ get ();
}

Remarks

Only flat and horizontal floor is valid for slab shape edit. Otherwise, ShapeEditor will be a null reference ( Nothing in Visual Basic) .

See Also