SpatialElementCalculationPoint Class


SpatialElementCalculationPoint is used as the search point for family instances placement inside rooms and spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public class SpatialElementCalculationPoint : SpatialElementCalculationLocation
Visual Basic
Public Class SpatialElementCalculationPoint _
	Inherits SpatialElementCalculationLocation
Visual C++
public ref class SpatialElementCalculationPoint : public SpatialElementCalculationLocation

Remarks

The Spatial Element Calculation Point is graphically showed as a location point marker with a "snake" line from the origin of the family. If the Spatial Element Calculation Point is turned on, this point will be used as a search point for room and space relations for all instances of this family.

Inheritance Hierarchy

See Also