PaneIsRegistered Method


Returns true if %id% refers to a built-in Revit dockable pane, or an add-in pane that has been properly registered with %Autodesk.Revit.UI.UIApplication.RegisterDockablePane%.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public static bool PaneIsRegistered(
	DockablePaneId id
)
Visual Basic
Public Shared Function PaneIsRegistered ( _
	id As DockablePaneId _
) As Boolean
Visual C++
public:
static bool PaneIsRegistered(
	DockablePaneId^ id
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also