Sets the datum plane for a given selector and direction.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- selector
- Type: Autodesk.Revit.DB.Structure AnalyticalElementSelector
End of the analytical model.
- direction
- Type: Autodesk.Revit.DB.Structure AnalyticalDirection
Direction in which analytical model may be projected.
- datumPlaneId
- Type: Autodesk.Revit.DB ElementId
Datum Plane on to which analytical model may be projected.
Remarks
Applicable for analytical models of linear elements (beams, braces, columns). This Datum Plane identifies a Level, a Grid, or a Ref Plane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | direction is invalid for analytical model -or- Datum Plane is invalid projection target. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |