ComboBoxMemberData Constructor


Constructs a new instance of ComboBoxMemberData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public ComboBoxMemberData(
	string name,
	string text
)
Visual Basic
Public Sub New ( _
	name As String, _
	text As String _
)
Visual C++
public:
ComboBoxMemberData(
	String^ name, 
	String^ text
)

Parameters

name
Type: System String
The internal name of the ComboBoxMember.
text
Type: System String
The user visible text seen on the item.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when a null reference ( Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions ArgumentException Thrown when an empty string is passed for one or more arguments.

See Also