Specify a variable-radius bend.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- vertexIndex
- Type: System Int32
Index of the vertex (1 to NumberOfVertices - 2).
- turn
- Type: Autodesk.Revit.DB.Structure RebarShapeVertexTurn
Specify turn direction (RebarShapeVertexTurn::Left or RebarShapeVertexTurn::Right).
- angle
- Type: Autodesk.Revit.DB.Structure RebarShapeBendAngle
Specify whether the bend is acute, obtuse, etc.
- paramId
- Type: Autodesk.Revit.DB ElementId
Id of a parameter driving the radius.
- measureIncludingBarThickness
- Type: System Boolean
If true, the radius is measured to the outside of the bend; if false, it is measured to the inside.
Remarks
You must add a bend between each two segments.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | vertexIndex is not between 0 and NumberOfVertices. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Reinforcement_Length or UT_Angle. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |