Parameter Property (Guid)


Obtains the parameter of this type with a given GUID for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public FamilyParameter this[
	Guid guid
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
	guid As Guid _
) As FamilyParameter
	Get
Visual C++
public:
property FamilyParameter^ Parameter[Guid guid] {
	FamilyParameter^ get (Guid guid);
}

Parameters

guid
Type: System Guid

Remarks

Returns a null reference ( Nothing in Visual Basic) if the parameter is not found. This method is used to retrieve a family parameter for a known shared parameter. When a shared parameter is created it is assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the element at a later time.

See Also