Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- location
- Type: Autodesk.Revit.DB XYZ
The physical location where the instance is to be placed.
- symbol
- Type: Autodesk.Revit.DB FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
- host
- Type: Autodesk.Revit.DB Element
The object into which the family instance is to be inserted, often known as the host.
- structuralType
- Type: Autodesk.Revit.DB.Structure StructuralType
If structural then specify the type of the component.