NewPlane Method (CurveArray)


Creates a new geometric plane from a loop of planar curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public Plane NewPlane(
	CurveArray curveloop
)
Visual Basic
Public Function NewPlane ( _
	curveloop As CurveArray _
) As Plane
Visual C++
public:
Plane^ NewPlane(
	CurveArray^ curveloop
)

Parameters

curveloop
Type: Autodesk.Revit.DB CurveArray
The closed loop of planar curves to locate plane.

Return Value

If successful a new geometric plane will be returned. Otherwise a null reference ( Nothing in Visual Basic) .

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Thrown when the input curve loop is a null reference ( Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions ArgumentException Thrown when the input curve loop does not lie in a plane.
Autodesk.Revit.Exceptions ArgumentException Thrown when the input curve loop is not closed.

See Also