SetCropRegionShape Method


Sets boundaries of crop region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public void SetCropRegionShape(
	CurveLoop boundaries
)
Visual Basic
Public Sub SetCropRegionShape ( _
	boundaries As CurveLoop _
)
Visual C++
public:
void SetCropRegionShape(
	CurveLoop^ boundaries
)

Parameters

boundaries
Type: Autodesk.Revit.DB CurveLoop
The crop region boundaries.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Boundaries in boundaries should represent one closed curve loop without self-intersections, consisting of non-zero length straight lines in plane parallel to the view plane.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException View is not allowed to manage crop region shape.

See Also