Starts an stairs edit mode for an existing Stairs element
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- stairsId
- Type: Autodesk.Revit.DB ElementId
The stairs element to be edited.
Return Value
ElementId of the editing stairs. It should be the same as the input stairsIdRemarks
User will need to start a transaction to actually make changes to the stairs element. StairsEditScope can only be started when there is no transaction active Thus it does not work for commands running in automatic transaction mode.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | It is not a Stair's id. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | StairsEditScope is not permitted to start at this moment for one of the following reasons: The document is in read-only state, or the document is currently modifiable, or there already is a stairs edit mode active in the document. |