The exception that is thrown when one of the arguments provided to a method is not valid.
Namespace:
Autodesk.Revit.Exceptions
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
This is the base class for exceptions that are thrown while validating the arguments to a function.
Inheritance Hierarchy
System
Object
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions ArgumentException
Autodesk.Revit.Exceptions ArgumentNullException
Autodesk.Revit.Exceptions ArgumentOutOfRangeException
Autodesk.Revit.Exceptions ArgumentsInconsistentException
Autodesk.Revit.Exceptions FileArgumentAlreadyExistsException
Autodesk.Revit.Exceptions FileArgumentNotFoundException
Autodesk.Revit.Exceptions InvalidPathArgumentException
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions ArgumentException
Autodesk.Revit.Exceptions ArgumentNullException
Autodesk.Revit.Exceptions ArgumentOutOfRangeException
Autodesk.Revit.Exceptions ArgumentsInconsistentException
Autodesk.Revit.Exceptions FileArgumentAlreadyExistsException
Autodesk.Revit.Exceptions FileArgumentNotFoundException
Autodesk.Revit.Exceptions InvalidPathArgumentException