SetStyleTransform Method


Sets the transform between the coordinate system of the type and the coordinate system of the instance's location in the Revit model.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public void SetStyleTransform(
	Transform trf
)
Visual Basic
Public Sub SetStyleTransform ( _
	trf As Transform _
)
Visual C++
public:
void SetStyleTransform(
	Transform^ trf
)

Parameters

trf
Type: Autodesk.Revit.DB Transform
The transform.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also