NewAreaLoad Method (IList(XYZ), XYZ, Boolean, AreaLoadType)


Creates a new uniform unhosted area load with polygonal shape within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public AreaLoad NewAreaLoad(
	IList<XYZ> points,
	XYZ force,
	bool isReaction,
	AreaLoadType symbol
)
Visual Basic
Public Function NewAreaLoad ( _
	points As IList(Of XYZ), _
	force As XYZ, _
	isReaction As Boolean, _
	symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
	IList<XYZ^>^ points, 
	XYZ^ force, 
	bool isReaction, 
	AreaLoadType^ symbol
)

Parameters

points
Type: System.Collections.Generic IList XYZ
Vertexes of AreaLoad shape polygon.
force
Type: Autodesk.Revit.DB XYZ
The applied 3d area force.
isReaction
Type: System Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. a null reference ( Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException If the product is not Revit Structure.

See Also