An object that represents a force/moment applied to a single point.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
Examples

private void Getinfo_PointLoad(PointLoad pointLoad)
{
string message = "Point Load :";
// Get the load case name
message += "\nLoad case for load: " + pointLoad.LoadCaseName;
//get the three dimensional force applied to the point load
message += "\nForce: (" + pointLoad.Force.X + ", " +
pointLoad.Force.Y + ", " + pointLoad.Force.Z + ")";
//get the three dimensional moment application to the point load
message += "\nMoment: (" + pointLoad.Moment.X + ", " +
pointLoad.Moment.Y + ", " + pointLoad.Moment.Z + ")";
//get the three dimensional coordinates of point load
message += "\nPoint load location: (" + pointLoad.Point.X + ", " +
pointLoad.Point.Y + ", " + pointLoad.Point.Z + ")";
TaskDialog.Show("Revit",message);
}

Private Sub Getinfo_PointLoad(pointLoad As PointLoad)
Dim message As String = "Point Load :"
' Get the load case name
message += vbLf & "Load case for load: " & Convert.ToString(pointLoad.LoadCaseName)
'get the three dimensional force applied to the point load
message += vbLf & "Force: (" & Convert.ToString(pointLoad.Force.X) & ", " & Convert.ToString(pointLoad.Force.Y) & ", " & Convert.ToString(pointLoad.Force.Z) & ")"
'get the three dimensional moment application to the point load
message += vbLf & "Moment: (" & Convert.ToString(pointLoad.Moment.X) & ", " & Convert.ToString(pointLoad.Moment.Y) & ", " & Convert.ToString(pointLoad.Moment.Z) & ")"
'get the three dimensional coordinates of point load
message += vbLf & "Point load location: (" & Convert.ToString(pointLoad.Point.X) & ", " & Convert.ToString(pointLoad.Point.Y) & ", " & Convert.ToString(pointLoad.Point.Z) & ")"
TaskDialog.Show("Revit", message)
End Sub
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB.Structure LoadBase
Autodesk.Revit.DB.Structure PointLoad
Autodesk.Revit.DB Element
Autodesk.Revit.DB.Structure LoadBase
Autodesk.Revit.DB.Structure PointLoad