SetShape Method (DirectShape)


Set a view-specific shape of the DirectShape object to geometry accumulated in this ViewShapeBuilder object. The view type currently set in ViewShapeBuilder is used. Since the accumulated geometry was validated by ViewShapeBuilder already, this skips the second validation in DirectShape. This function resets this ViewShapeBuilder object: the geometry is transferred to DirectShape, view normal and view type are invalidated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public void SetShape(
	DirectShape directShape
)
Visual Basic
Public Sub SetShape ( _
	directShape As DirectShape _
)
Visual C++
public:
void SetShape(
	DirectShape^ directShape
)

Parameters

directShape
Type: Autodesk.Revit.DB DirectShape
The DirectShape object that will have its view-specific shape representation set to a copy of geometry accumulated in this DirectShapeBuilder.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also