Creates a new parameter definition using name, type and visibility.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- name
- Type: System String
The name of the parameter definition to be created.
- type
- Type: Autodesk.Revit.DB ParameterType
The name of the parameter type for the new definition.
- visible
- Type: System Boolean
True if the parameter is visible to the user, false if it is hidden and accessible only via the API.
Return Value
If successful a reference to the new parameter definition is returned, otherwise a null reference ( Nothing in Visual Basic) .Remarks
This method only supports creation of new external defintions (shared parameters).