Returns the active workset's WorksetId.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
WorksetId of the active workset.Examples

public Workset GetActiveWorkset(Document doc)
{
// Get the workset table from the document
WorksetTable worksetTable = doc.GetWorksetTable();
// Get the Id of the active workset
WorksetId activeId = worksetTable.GetActiveWorksetId();
// Find the workset with that Id
Workset workset = worksetTable.GetWorkset(activeId);
return workset;
}

Public Function GetActiveWorkset(doc As Document) As Workset
' Get the workset table from the document
Dim worksetTable As WorksetTable = doc.GetWorksetTable()
' Get the Id of the active workset
Dim activeId As WorksetId = worksetTable.GetActiveWorksetId()
' Find the workset with that Id
Dim workset As Workset = worksetTable.GetWorkset(activeId)
Return workset
End Function