GetLinkLoadResult Method


Retrieves the LinkLoadResult of the attempt to load or reload a Revit link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public RevitLinkLoadResult GetLinkLoadResult()
Visual Basic
Public Function GetLinkLoadResult As RevitLinkLoadResult
Visual C++
public:
RevitLinkLoadResult^ GetLinkLoadResult()

Return Value

A LinkLoadObject containing the status and other information about an attempt by Revit to load a Revit link.

Remarks

A LinkLoadResult object is included in the LinkLoadContent class so that IExternalResourceUIServers will have additional information about the status of the link to display to the user.

The LinkLoadResult is added to the LinkLoadContent object during the load operation, after the IExternalResourceServer LoadResource method has been called. Consequently, this method will return NULL if called from the LoadResource method of an IExternalResourceServer.

See Also